LEAP United States

Service Disruption
Incident Report for LEAP United States
Resolved
Some users may have experienced difficulty logging into LEAP. We have identified the issue and it is now resolved.
Posted Jan 25, 2025 - 04:51 EST
Identified
Some users may be experiencing intermittent errors while using LEAP. We have identified the issue and we are working urgently to resolve these issues. We will provide an updated status when we have resolved the issue.
Posted Jan 25, 2025 - 04:49 EST
This incident affected: LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile, and LEAP 365.